diff options
Diffstat (limited to 'nix/package.nix')
-rw-r--r-- | nix/package.nix | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/nix/package.nix b/nix/package.nix new file mode 100644 index 0000000..149fb58 --- /dev/null +++ b/nix/package.nix | |||
@@ -0,0 +1,33 @@ | |||
1 | { | ||
2 | src, | ||
3 | version, | ||
4 | |||
5 | lib, | ||
6 | stdenv, | ||
7 | nix-update-script, | ||
8 | nim, | ||
9 | }: | ||
10 | |||
11 | stdenv.mkDerivation (final: { | ||
12 | pname = "tickwatch"; | ||
13 | inherit version src; | ||
14 | |||
15 | buildInputs = [ nim ]; | ||
16 | doCheck = true; | ||
17 | makeFlags = [ | ||
18 | "NIM_FLAGS=--nimcache:." | ||
19 | "VERSION=v${final.version}" | ||
20 | ]; | ||
21 | installFlags = [ "DESTDIR=$(out)" ]; | ||
22 | |||
23 | passthru.updateScript = nix-update-script { }; | ||
24 | |||
25 | meta = { | ||
26 | homepage = "https://cgit.euxane.eu/tickwatch/about/"; | ||
27 | changelog = "https://cgit.euxane.eu/tickwatch/tree/changelog.md?h=v${final.version}"; | ||
28 | description = "Terminal monitoring and visualization tool"; | ||
29 | license = lib.licenses.eupl12; | ||
30 | maintainers = with lib.maintainers; [ euxane ]; | ||
31 | mainProgram = "tickwatch"; | ||
32 | }; | ||
33 | }) | ||